Mytop error in option spec long|! with RHEL or CentOS 5.3

Mytop has started to break recently when upgrading from RHEL or CentOS 5.x to 5.3. It appears that some of the perl modules have change.d

There error is:
#mytop
Error in option spec: "long|!"

The fix for this is to edit the mytop script and comment out the line containing long|!

pico /usr/bin/mytop

Run a search for long|! and comment out the following line:

"long|!" => \$config{long_nums},

Start mytop and you should be fine!

Articles and guides: